Both websites are down

Ok Alex, yes i will try with that domain, thank you

Any help with that guys? When I try to claim mir tokens as rewards i receive this error messagge:

First argument must be a string, Buffer, ArrayBuffer, Array, or array-like object.

My web terra wallet is in clasic mode and I have enough UST for fees

4 days ago I withdraw without problems

“First argument must be a string, Buffer, ArrayBuffer, Array, or array-like object”

Can you post screenshot?

yes

oui,

Maybe at vercel app deployed older version, than at github. I see there was some changes at 29 May.

I will try to deploy last github version

Yes it will be great…I’ve tried on chrome, on brave and even on microsofot edge browsers but it did not work… smiling_face_with_tear:

A separate deployment did not solve the problem. Apparently there were more fixes after May 29.

I created telegram chat.

I propose to discuss the solution of the problem also there:

@ mirrorprotocol_group

I have the same problem -
Logged on to Mirror Protocol using this link (https://terra-web-dapp.vercel.app/ ) and a new surprise emerged. The Governance interphase says my tokens are still staked on three different poles hence not allowing unstaking. Each of these poles are actually passed poles that had ended. Last one being on Oct 24.

Any help would be appreciated - Thanks

I create issue on github. Maybe it helps to solve the problem

Previous polls - before the last three polls - are tagged either “Executed (passed)” or “Rejected (did not pass)”-

the final three area tagged “In Progeress” but scratched (see below) - could this be why the tokens are stuck in the voting.

I managed to unstake my MIR rewards, everything is intact.
Here’s what I did:

Go to the MIR staking contract, in my case was something like
Terra Station (more on how to find your staking contract address below)

Execute the following:

{
“withdraw_voting_tokens”: {
“amount”: “488969573”
}
}

Note the amount is multiplied by 1 Million, I don’t know why. In your case you should match your amount. I was not sure, but you can change the value and the platform will complain if you exceed it.

How did I know my contract? I went to

https://finder.terra.money/classic/address/terra_your_wallet_address

Replace “terra_your_wallet_address” by your public address of your wallet, and scroll to the bottom of the page, where it shows your past transactions. Find the line which says “MsgExecuteContract” and where in the column “Out” or “In” says some amount in MIR like so, for example:

Click on the transaction details (left-most link)
Then scroll down and find this entry:

The scrapped section on my case is exactly the address you need to replace on the first step.

Hope it helps. It just works. And it just goes to show that the mirror finance app page is really just a front-end UI. All contract information is in the ledger, so funds are safe.

Cheers, and keep calm.

Do not go to anyones app that claims they have the site up. It might be compromised.
Everything is possible to do via the Terra Station. See my post just a couple of minutes ago with the example of MIR.

Does this apply to “unstaking” the tokens staked under “Govern”?

Yep, it does, sorry, my initial post mentioning MIR rewards is misleading. It’s to unstake the amount under governance as you said

Hi, I was able to also retrieve most of my staked funds in non-crypto staking (non mBTC-USTC and non mETH-USTC). I am posting how I did it.
I am not an expert and do not fully understand the contract addresses nor I know if there is a single contract staking address for each asset or more. Therefore I’ll try to make this as best as possible.

You need basically 2 main tools: https://finder.terra.money to see a history transaction of your wallet. Go to Terra Finder<your_wallet_address> to see all your wallet transactions. scroll to the bottom of the page and click “MORE” to see more historical actions. Keep clicking so you get as many historical transactions on the screen as possible.

The method is based on inspecting your old unstaking transactions and repeating the same patterns. So for instance, to unstake your mPYPL-USTC assets you need 3 major steps:

  1. Unbound
  2. Withdraw
  3. Swap to USTC (the portion that is non-USTC) (optional)

The example I’m showing is for mPYPL but this works for any mAsset, (except for crypto mAssets which I was not able to apply this for some reason I don’t know).

=========================================================

  1. Find a previous mPYPL transaction saying “token” (negative amount) on “Amount (out) column”. For example:

Then click on the left-most link of that transaction (Transaction Details). IMPORTANT: The Transaction Details should have 2 sections with 2 different messages: One saying “Transfer” and another one saying “Withdraw”.
For step 1 scroll down to the “Transfer” section of that page as so:

Save the “Staking Contract” address. Use that address for later.

That JSON message:

{
  "unbond": {
    "amount": "xxxx",
    "asset_token": "terra1rh2907984nudl7vh56qjdtvv7947z4dujj92sx"
  }
}

With the amount applicable to your funds is the important unbound message. The value there should have your LP tokens staked. There are no decimal spaces in that value so for instance if you had 100 uLP staked the value to put in the JSON message (amount) must have 6 more zeroes, 100000000. If your amount is something like this “107.456738” then remove the decimal spaces dot as so: “107456738”.

Go now to Terra Station<your_staking_contract_address> with the “Staking Contract” address you saved previously.
Copy paste that JSON message above. Click Execute. If all goes well, your terra station wallet widget should pop-up prompting you to enter your password.

=========================================================
2. For step 2 scroll down to the “Withdraw” section of that page as so:

See the contract that’s mentioned there. Copy that contract and Go to Terra station to execute on top of it:
Terra Station<the_contract_on_the_withdraw_section>
The JSON message this time to execute is different:

{
  "send": {
    "msg": "eyJ3aXRoZHJhd19saXF1aWRpdHkiOnt9fQ==",
    "amount": "191457564",
    "contract": "terra1xskmucgxkzf3quwry3dazerw74q4aqplu0vgg4"
  }
}

“msg”: keep the same!
“amount”: adjust as the previous step to your staked amount
“contract”: keep the same!

Click execute and if everything goes well again you now should already see the USTC portion deducted to our USTC wallet amount :slight_smile:

You should also see your other asset in your wallet by now: It’s yours, its safe now :slight_smile:

=========================================================
3. The last part is to SWAP your mASSET 50% portion which was staked back into USTC (unless you want to keep it as is) - so this is OPTIONAL:

Go to Terra Finder<your_wallet_address>
And now find a historical previous swap message of your mASSET my USTC, something like this:

In the “Amount (out)” column you should see a negative mAsset value of the mAsset you want to swap from, and in the “Amount (in)” column you should see a positive value in USTC. Click on those transaction details.

Go to:
Terra Station<your_asset_contract>
The above is the contract from the “asset_token” in your unbound message in step 1!
Then execute the following JSON message:

The transaction details of your SWAP message should look like something like below:

{
  "send": {
    "msg": "eyJzd2FwIjp7ImJlbGllZl9wcmljZSI6IjAuMDE1MTkwMzUwNDkwMDU3MjkxIiwibWF4X3NwcmVhZCI6IjAuMDEzIn19",
    "amount": "20180793",
    "contract": "terra1xskmucgxkzf3quwry3dazerw74q4aqplu0vgg4"
  }
}

“msg”: Keep unchanged!
“amount”: adjust to what you need! If you don’t know the value, play with it, start with the highest value as the console will warn you you don’t have that much money and then work your way down until it shows the dropdown field for you to choose whether to pay in USTC or LUNC for fees.
“contract”: It’s EXACTLY the same contract as in step 2 in the JSON “contract” field.

If everything works, you now should have your mAsset swapped back to USTC.

That’s it!

To me it worked for MOST of my assets EXCEPT:

  • mETH
  • mBTC
  • and very strangely, mIAU (I am not sure why is that)

Hope it helps,
Cheers,

Just to add, if anybody has sorted out the withdrawal for crypto mAssets would appreciate it if you can share was as well! :slight_smile:

https://terra-mirrorprotocol.vercel.app/#/my
Just claimed my short farming tokens :slight_smile:

1 Like