BUG: Can not close position

Hello,

Can not close out my short position. See screen shots included.

  1. Short position: Netflix
  2. Click Manage
  3. Click Close on “Manage dialog”
  4. Click Buy mNFLX to close position
  5. On Trade dialog: notice the buy amount is zero. I can not put any value in there without it showing “simulation failed”.
    Note: it shows there is $43.15 UST which is plenty of UST to close this position out. I have closed out other positions for both long and shorts. This has worked previously.

It seems like there is a bug.

Thank you

1 Like

You need to enter non-zero value in the UST field. It was shown as available 43.15 but you only 0 is selected.

1 Like

I just tried it, it should be able to enter a UST amount, a mAsset amount, or paste the exact amount from the short position into the mAsset amount.

Try closing your browser and try again or use another browser altogether (im using Chrome)

The UI could use some improvement, it probably be better if it tells you how much of the mAsset you need to in order to close your position and redirect you to buy or allow you to buy and close right there.

Appreciate the responses. I actually did fill in the amount to buy that would close out the short position, but it stated “simulation failed” and the button was not activated. Tried various amounts and it did not work. I have closed out shorts and longs previous and it worked.

i have seem failed simulation errors before. This is a wild guess but, try a larger amount and see if it works

That worked! It was too small of a amount to buy. The minimum was 0.103 in this case.

I am unraveling one last piece and it’s having a different issues. Enclosed pics.

  1. Long position: mSQ
  2. Click Manage
  3. Click Close on “Manage dialog”
  4. Click Buy: notice mSQ amount is “zero”. This make sense since I previously “sold” the amount that I had to close this out. It is not showing the close button here as normal. No matter how much I put in the mSQ amount, it can not do anything since I no longer have any mSQ.

It’s in a stuck state. A colleague of mine is having the same issue. I believe he posted a video yesterday.

Thank you!





Got it to work. On the long position I had to purchase mSQ. But for some reason I had to top it up a bit higher. Then I was able to sell and then close. It has a strange 0.000497 aUST collateral on the books. So it could not close out.

All done. Thank you for everyones support!